use strict;
my $str = '312345678901234
3123456789012344
\\s*(?:\\S\\s*)';
my $regex = qr/[4|3|5]([0-9[:space:]\t]{29,31})|[4|3|5]([0-9\s\S\w+]{28})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}