#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(ebay(\.[a-z]{2,3}){1,2}/(itm|link/\?nav=item))"
Local $sString = "SHOULD MATCH" & @CRLF & _
"" & @CRLF & _
"ebay.com/itm" & @CRLF & _
"" & @CRLF & _
"ebay.nl/itm" & @CRLF & _
"" & @CRLF & _
"anything.ebay.co.uk/link/?nav=item" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"SHOULD NOT MATCH" & @CRLF & _
"" & @CRLF & _
"Customer service: http://ocsnext.ebay.com/ocs/home?" & @CRLF & _
"" & @CRLF & _
"Sign in: https://signin.ebay.com/ws/" & @CRLF & _
"" & @CRLF & _
"Privacy policy: http://pages.ebay.com/help/policies/user-agreement.html?rt=nc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")