import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(ebay(\\.[a-z]{2,3}){1,2}/(itm|link/\\?nav=item))";
final String string = "SHOULD MATCH\n\n"
+ "ebay.com/itm\n\n"
+ "ebay.nl/itm\n\n"
+ "anything.ebay.co.uk/link/?nav=item\n\n\n"
+ "SHOULD NOT MATCH\n\n"
+ "Customer service: http://ocsnext.ebay.com/ocs/home?\n\n"
+ "Sign in: https://signin.ebay.com/ws/\n\n"
+ "Privacy policy: http://pages.ebay.com/help/policies/user-agreement.html?rt=nc";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}