$re = '/(ebay(\.[a-z]{2,3}){1,2}/(itm|link/\?nav=item))/';
$str = 'SHOULD MATCH
ebay.com/itm
ebay.nl/itm
anything.ebay.co.uk/link/?nav=item
SHOULD NOT MATCH
Customer service: http://ocsnext.ebay.com/ocs/home?
Sign in: https://signin.ebay.com/ws/
Privacy policy: http://pages.ebay.com/help/policies/user-agreement.html?rt=nc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);