import Foundation
let pattern = #"(ebay(\.[a-z]{2,3}){1,2}/(itm|link/\?nav=item))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
SHOULD MATCH
ebay.com/itm
ebay.nl/itm
anything.ebay.co.uk/link/?nav=item
SHOULD NOT MATCH
Customer service: http://ocsnext.ebay.com/ocs/home?
Sign in: https://signin.ebay.com/ws/
Privacy policy: http://pages.ebay.com/help/policies/user-agreement.html?rt=nc
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)