const regex = new RegExp('(ebay(\\.[a-z]{2,3}){1,2}/(itm|link/\\?nav=item))', 'g')
const str = `SHOULD MATCH
ebay.com/itm
ebay.nl/itm
anything.ebay.co.uk/link/?nav=item
SHOULD NOT MATCH
Customer service: http://ocsnext.ebay.com/ocs/home?
Sign in: https://signin.ebay.com/ws/
Privacy policy: http://pages.ebay.com/help/policies/user-agreement.html?rt=nc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}