#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\s|^)(?:[\d_]\S+|\S*[%@#$]\S*)(?=\s|$)"
Local $sString = "3testData" & @CRLF & _
"_testData" & @CRLF & _
"%data%" & @CRLF & _
"test%BIN%data this is #etst" & @CRLF & _
"test_Data3" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"3testData" & @CRLF & _
"_testData" & @CRLF & _
"%data%" & @CRLF & _
"test%BIN%data" & @CRLF & _
"test%BIN%data" & @CRLF & _
"te$t&$#@daTa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")