using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\s|^)(?:[\d_]\S+|\S*[%@#$]\S*)(?=\s|$)";
string input = @"3testData
_testData
%data%
test%BIN%data this is #etst
test_Data3
3testData
_testData
%data%
test%BIN%data
test%BIN%data
te$t&$#@daTa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}