import Foundation
let pattern = ##"(?<=\s|^)(?:[\d_]\S+|\S*[%@#$]\S*)(?=\s|$)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
3testData
_testData
%data%
test%BIN%data this is #etst
test_Data3
3testData
_testData
%data%
test%BIN%data
test%BIN%data
te$t&$#@daTa
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)