re = /(?<=\s|^)(?:[\d_]\S+|\S*[%@#$]\S*)(?=\s|$)/m
str = '3testData
_testData
%data%
test%BIN%data this is #etst
test_Data3
3testData
_testData
%data%
test%BIN%data
test%BIN%data
te$t&$#@daTa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end