import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\s|^)(?:[\\d_]\\S+|\\S*[%@#$]\\S*)(?=\\s|$)";
final String string = "3testData\n"
+ "_testData\n"
+ "%data%\n"
+ "test%BIN%data this is #etst\n"
+ "test_Data3\n\n\n"
+ "3testData\n"
+ "_testData\n"
+ "%data%\n"
+ "test%BIN%data\n"
+ "test%BIN%data\n"
+ "te$t&$#@daTa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}