$re = '/(?<=\s|^)(?:[\d_]\S+|\S*[%@#$]\S*)(?=\s|$)/m';
$str = '3testData
_testData
%data%
test%BIN%data this is #etst
test_Data3
3testData
_testData
%data%
test%BIN%data
test%BIN%data
te$t&$#@daTa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);