#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"title": "[^"]*""
Local $sString = "1. Есть строки в текстовом файле: "title": "разный текст"" & @CRLF & _
"Найти всё в этом файле." & @CRLF & _
"2. Есть строки в текстовом файле:" & @CRLF & _
""url": "разный текст"" & @CRLF & _
"Найти всё в этом файле." & @CRLF & _
"" & @CRLF & _
"3. Есть всё в общей строке в текстовом файле:" & @CRLF & _
""title": "разный текст", "url": "разный текст""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")