// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"title": "[^"]*""#).unwrap();
let string = "1. Есть строки в текстовом файле: \"title\": \"разный текст\"
Найти всё в этом файле.
2. Есть строки в текстовом файле:
\"url\": \"разный текст\"
Найти всё в этом файле.
3. Есть всё в общей строке в текстовом файле:
\"title\": \"разный текст\", \"url\": \"разный текст\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}