re = /"title": "[^"]*"/m
str = '1. Есть строки в текстовом файле: "title": "разный текст"
Найти всё в этом файле.
2. Есть строки в текстовом файле:
"url": "разный текст"
Найти всё в этом файле.
3. Есть всё в общей строке в текстовом файле:
"title": "разный текст", "url": "разный текст"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end