package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"title": "[^"]*"`)
var str = `1. Есть строки в текстовом файле: "title": "разный текст"
Найти всё в этом файле.
2. Есть строки в текстовом файле:
"url": "разный текст"
Найти всё в этом файле.
3. Есть всё в общей строке в текстовом файле:
"title": "разный текст", "url": "разный текст"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}