using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""title"": ""[^""]*""";
string input = @"1. Есть строки в текстовом файле: ""title"": ""разный текст""
Найти всё в этом файле.
2. Есть строки в текстовом файле:
""url"": ""разный текст""
Найти всё в этом файле.
3. Есть всё в общей строке в текстовом файле:
""title"": ""разный текст"", ""url"": ""разный текст""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}