#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)([^.]*ALPHA[^.]*)([^.]*BETA[^.]*)"
Local $sString = "ALPHA|checkagainst|(BETA_val)fd"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)