const regex = /([^.]*ALPHA[^.]*)([^.]*BETA[^.]*)/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^.]*ALPHA[^.]*)([^.]*BETA[^.]*)', 'igm')
const str = `ALPHA|checkagainst|(BETA_val)fd`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);