$re = '/([^.]*ALPHA[^.]*)([^.]*BETA[^.]*)/im';
$str = 'ALPHA|checkagainst|(BETA_val)fd';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;