import re
regex = re.compile(r"([^.]*ALPHA[^.]*)([^.]*BETA[^.]*)", flags=re.IGNORECASE | re.MULTILINE)
test_str = "ALPHA|checkagainst|(BETA_val)fd"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)