use strict;
my $str = 'ALPHA|checkagainst|(BETA_val)fd';
my $regex = qr/([^.]*ALPHA[^.]*)([^.]*BETA[^.]*)/imp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";