using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^.]*ALPHA[^.]*)([^.]*BETA[^.]*)";
string substitution = @"";
string input = @"ALPHA|checkagainst|(BETA_val)fd";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}