#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^([a-zA-Z][\s\S]*?)\<br\>"
Local $sString = "Лорем ипсум<br>привет мир<br>голактеко опасносте<br>Лорем ипсум<br>" & @CRLF & _
"Lorem ipsum dolor <a href="">sit</a> amet, consectetur adipisicing elit.<br>" & @CRLF & _
"<br>" & @CRLF & _
"<img src="img.jpg" alt="">" & @CRLF & _
"<br>" & @CRLF & _
"Lorem ipsum dolor sit amet, consectetur <a href="">adipisicing</a> elit.<br>" & @CRLF & _
"<br>" & @CRLF & _
"<div class="inner">Lorem ipsum dolor sit amet, consectetur adipisicing elit. Impedit, voluptas.</div>" & @CRLF & _
"<br>" & @CRLF & _
"Lorem ipsum <span>dolor</span> sit amet, consectetur adipisicing elit.<br>" & @CRLF & _
"<br>" & @CRLF & _
"<div>" & @CRLF & _
" <img src="img.jpg" alt="">" & @CRLF & _
"</div>" & @CRLF & _
"<br>" & @CRLF & _
"Lorem <b>ipsum</b> dolor sit amet, consectetur adipisicing elit.<br>" & @CRLF & _
"<br>" & @CRLF & _
"<div>Lorem...</div>" & @CRLF & _
"<br>" & @CRLF & _
"Lorem ipsum dolor sit amet, consectetur adipisicing elit.<br>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")