import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z][\\s\\S]*?)\\<br\\>";
final String string = "Лорем ипсум<br>привет мир<br>голактеко опасносте<br>Лорем ипсум<br>\n"
+ "Lorem ipsum dolor <a href=\"\">sit</a> amet, consectetur adipisicing elit.<br>\n"
+ "<br>\n"
+ "<img src=\"img.jpg\" alt=\"\">\n"
+ "<br>\n"
+ "Lorem ipsum dolor sit amet, consectetur <a href=\"\">adipisicing</a> elit.<br>\n"
+ "<br>\n"
+ "<div class=\"inner\">Lorem ipsum dolor sit amet, consectetur adipisicing elit. Impedit, voluptas.</div>\n"
+ "<br>\n"
+ "Lorem ipsum <span>dolor</span> sit amet, consectetur adipisicing elit.<br>\n"
+ "<br>\n"
+ "<div>\n"
+ " <img src=\"img.jpg\" alt=\"\">\n"
+ "</div>\n"
+ "<br>\n"
+ "Lorem <b>ipsum</b> dolor sit amet, consectetur adipisicing elit.<br>\n"
+ "<br>\n"
+ "<div>Lorem...</div>\n"
+ "<br>\n"
+ "Lorem ipsum dolor sit amet, consectetur adipisicing elit.<br>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}