const regex = /^([a-zA-Z][\s\S]*?)\<br\>/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z][\\s\\S]*?)\\<br\\>', 'gim')
const str = `Лорем ипсум<br>привет мир<br>голактеко опасносте<br>Лорем ипсум<br>
Lorem ipsum dolor <a href="">sit</a> amet, consectetur adipisicing elit.<br>
<br>
<img src="img.jpg" alt="">
<br>
Lorem ipsum dolor sit amet, consectetur <a href="">adipisicing</a> elit.<br>
<br>
<div class="inner">Lorem ipsum dolor sit amet, consectetur adipisicing elit. Impedit, voluptas.</div>
<br>
Lorem ipsum <span>dolor</span> sit amet, consectetur adipisicing elit.<br>
<br>
<div>
<img src="img.jpg" alt="">
</div>
<br>
Lorem <b>ipsum</b> dolor sit amet, consectetur adipisicing elit.<br>
<br>
<div>Lorem...</div>
<br>
Lorem ipsum dolor sit amet, consectetur adipisicing elit.<br>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}