use strict;
my $str = 'Лорем ипсум<br>привет мир<br>голактеко опасносте<br>Лорем ипсум<br>
Lorem ipsum dolor <a href="">sit</a> amet, consectetur adipisicing elit.<br>
<br>
<img src="img.jpg" alt="">
<br>
Lorem ipsum dolor sit amet, consectetur <a href="">adipisicing</a> elit.<br>
<br>
<div class="inner">Lorem ipsum dolor sit amet, consectetur adipisicing elit. Impedit, voluptas.</div>
<br>
Lorem ipsum <span>dolor</span> sit amet, consectetur adipisicing elit.<br>
<br>
<div>
<img src="img.jpg" alt="">
</div>
<br>
Lorem <b>ipsum</b> dolor sit amet, consectetur adipisicing elit.<br>
<br>
<div>Lorem...</div>
<br>
Lorem ipsum dolor sit amet, consectetur adipisicing elit.<br>';
my $regex = qr/^([a-zA-Z][\s\S]*?)\<br\>/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}