# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([a-zA-Z][\s\S]*?)\<br\>"
test_str = ("Лорем ипсум<br>привет мир<br>голактеко опасносте<br>Лорем ипсум<br>\n"
"Lorem ipsum dolor <a href=\"\">sit</a> amet, consectetur adipisicing elit.<br>\n"
"<br>\n"
"<img src=\"img.jpg\" alt=\"\">\n"
"<br>\n"
"Lorem ipsum dolor sit amet, consectetur <a href=\"\">adipisicing</a> elit.<br>\n"
"<br>\n"
"<div class=\"inner\">Lorem ipsum dolor sit amet, consectetur adipisicing elit. Impedit, voluptas.</div>\n"
"<br>\n"
"Lorem ipsum <span>dolor</span> sit amet, consectetur adipisicing elit.<br>\n"
"<br>\n"
"<div>\n"
" <img src=\"img.jpg\" alt=\"\">\n"
"</div>\n"
"<br>\n"
"Lorem <b>ipsum</b> dolor sit amet, consectetur adipisicing elit.<br>\n"
"<br>\n"
"<div>Lorem...</div>\n"
"<br>\n"
"Lorem ipsum dolor sit amet, consectetur adipisicing elit.<br>")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.