#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "cast([^\n]+\n){0,2}[^\n]*datetime"
Local $sString = "cast('"+ object.method()+ "' as datetime" & @CRLF & _
"cast('"+ " & @CRLF & _
"object.method()+ "' as datetime" & @CRLF & _
"cast('"+ " & @CRLF & _
"object.method()+ "' " & @CRLF & _
"as datetime" & @CRLF & _
"cast('" & @CRLF & _
""+ object.method()+ "'" & @CRLF & _
" as" & @CRLF & _
" datetime" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")