// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"cast([^\n]+\n){0,2}[^\n]*datetime").unwrap();
let string = "cast('\"+ object.method()+ \"' as datetime
cast('\"+
object.method()+ \"' as datetime
cast('\"+
object.method()+ \"'
as datetime
cast('
\"+ object.method()+ \"'
as
datetime
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}