re = /cast([^\n]+\n){0,2}[^\n]*datetime/
str = 'cast(\'"+ object.method()+ "\' as datetime
cast(\'"+
object.method()+ "\' as datetime
cast(\'"+
object.method()+ "\'
as datetime
cast(\'
"+ object.method()+ "\'
as
datetime
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end