package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`cast([^\n]+\n){0,2}[^\n]*datetime`)
var str = `cast('"+ object.method()+ "' as datetime
cast('"+
object.method()+ "' as datetime
cast('"+
object.method()+ "'
as datetime
cast('
"+ object.method()+ "'
as
datetime
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}