using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"public\.(?!(bg|cp)_)[^_]+_.*";
string input = @"public.bg_table1
public.bg_table2
public.cp_table1
public.my_table1
public.user_action
public.cp1_table1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}