import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "public\\.(?!(bg|cp)_)[^_]+_.*";
final String string = "public.bg_table1\n"
+ "public.bg_table2\n"
+ "public.cp_table1\n"
+ "public.my_table1\n"
+ "public.user_action\n"
+ "public.cp1_table1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}