const regex = /public\.(?!(bg|cp)_)[^_]+_.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('public\\.(?!(bg|cp)_)[^_]+_.*', 'gm')
const str = `public.bg_table1
public.bg_table2
public.cp_table1
public.my_table1
public.user_action
public.cp1_table1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}