re = /public\.(?!(bg|cp)_)[^_]+_.*/m
str = 'public.bg_table1
public.bg_table2
public.cp_table1
public.my_table1
public.user_action
public.cp1_table1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end