import re
regex = re.compile(r"public\.(?!(bg|cp)_)[^_]+_.*", flags=re.MULTILINE)
test_str = ("public.bg_table1\n"
"public.bg_table2\n"
"public.cp_table1\n"
"public.my_table1\n"
"public.user_action\n"
"public.cp1_table1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")