use strict;
my $str = 'Usage:
diagrammer [--debug] [--output=<file>] <input-file>
diagrammer --help
Options:
--debug, -d Draw the diagram upon a grid.
--help Show this message and exit.
--output=<file> Place output in file \'file\'. [default: output.png]
Copyright Evgeny Gagauz, 2016.
';
my $regex = qr/(?:^|\n)([^\n]*options:[^\n]*(?=\n?)(?:\n+[ \t].*?(?=\n|$))*)/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}