re = /(?:^|\n)([^\n]*options:[^\n]*(?=\n?)(?:\n+[ \t].*?(?=\n|$))*)/i
str = 'Usage:
diagrammer [--debug] [--output=<file>] <input-file>
diagrammer --help
Options:
--debug, -d Draw the diagram upon a grid.
--help Show this message and exit.
--output=<file> Place output in file \'file\'. [default: output.png]
Copyright Evgeny Gagauz, 2016.
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end