$re = '/(?:^|\n)([^\n]*options:[^\n]*(?=\n?)(?:\n+[ \t].*?(?=\n|$))*)/i';
$str = 'Usage:
diagrammer [--debug] [--output=<file>] <input-file>
diagrammer --help
Options:
--debug, -d Draw the diagram upon a grid.
--help Show this message and exit.
--output=<file> Place output in file \'file\'. [default: output.png]
Copyright Evgeny Gagauz, 2016.
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);