#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?=.?\d)(?!(.*?\.){2,})[\d.]+$|^(?=.?\d)(?!(.*?,){2,})[\d,]+$"
Local $sString = "1" & @CRLF & _
"123" & @CRLF & _
"123." & @CRLF & _
"123.4" & @CRLF & _
"123.456" & @CRLF & _
".456" & @CRLF & _
"123," & @CRLF & _
"123,4" & @CRLF & _
"123,456" & @CRLF & _
",456" & @CRLF & _
"0.,1" & @CRLF & _
"0a,1" & @CRLF & _
"0..1" & @CRLF & _
"1.1.2" & @CRLF & _
"100,000.99" & @CRLF & _
"100.000,99" & @CRLF & _
"," & @CRLF & _
"."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)