use strict;
my $str = '1
123
123.
123.4
123.456
.456
123,
123,4
123,456
,456
0.,1
0a,1
0..1
1.1.2
100,000.99
100.000,99
,
.';
my $regex = qr/^(?=.?\d)(?!(.*?\.){2,})[\d.]+$|^(?=.?\d)(?!(.*?,){2,})[\d,]+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";