$re = '/^(?=.?\d)(?!(.*?\.){2,})[\d.]+$|^(?=.?\d)(?!(.*?,){2,})[\d,]+$/m';
$str = '1
123
123.
123.4
123.456
.456
123,
123,4
123,456
,456
0.,1
0a,1
0..1
1.1.2
100,000.99
100.000,99
,
.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;