const regex = new RegExp('^(?=.?\\d)(?!(.*?\\.){2,})[\\d.]+$|^(?=.?\\d)(?!(.*?,){2,})[\\d,]+$', 'gm')
const str = `1
123
123.
123.4
123.456
.456
123,
123,4
123,456
,456
0.,1
0a,1
0..1
1.1.2
100,000.99
100.000,99
,
.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);