# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.?\d)(?!(.*?\.){2,})[\d.]+$|^(?=.?\d)(?!(.*?,){2,})[\d,]+$"
test_str = ("1\n"
"123\n"
"123.\n"
"123.4\n"
"123.456\n"
".456\n"
"123,\n"
"123,4\n"
"123,456\n"
",456\n"
"0.,1\n"
"0a,1\n"
"0..1\n"
"1.1.2\n"
"100,000.99\n"
"100.000,99\n"
",\n"
".")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.