import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.?\\d)(?!(.*?\\.){2,})[\\d.]+$|^(?=.?\\d)(?!(.*?,){2,})[\\d,]+$";
final String string = "1\n"
+ "123\n"
+ "123.\n"
+ "123.4\n"
+ "123.456\n"
+ ".456\n"
+ "123,\n"
+ "123,4\n"
+ "123,456\n"
+ ",456\n"
+ "0.,1\n"
+ "0a,1\n"
+ "0..1\n"
+ "1.1.2\n"
+ "100,000.99\n"
+ "100.000,99\n"
+ ",\n"
+ ".";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}