#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<type>[^\s]+)\s(?<name>[^\s]+)(?=\s\{get;)"
Local $sString = "public class User " & @CRLF & _
"{" & @CRLF & _
" //Some code here" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"public class Cars" & @CRLF & _
"{" & @CRLF & _
" public string Brand {get; set;}" & @CRLF & _
" public string YearModel {get; set;}" & @CRLF & _
" public List<User> HasRented {get; set;}" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")