import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "(?<type>[^\\s]+)\\s(?<name>[^\\s]+)(?=\\s\\{get;)";
        final String string = "public class User \n"
	 + "{\n"
	 + "   //Some code here\n"
	 + "}\n\n\n"
	 + "public class Cars\n"
	 + "{\n"
	 + "  public string Brand {get; set;}\n"
	 + "  public string YearModel {get; set;}\n"
	 + "  public List<User> HasRented {get; set;}\n"
	 + "}";
        
        final Pattern pattern = Pattern.compile(regex);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}