import re
regex = re.compile(r"(?<type>[^\s]+)\s(?<name>[^\s]+)(?=\s\{get;)")
test_str = ("public class User \n"
"{\n"
" //Some code here\n"
"}\n\n\n"
"public class Cars\n"
"{\n"
" public string Brand {get; set;}\n"
" public string YearModel {get; set;}\n"
" public List<User> HasRented {get; set;}\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")