const regex = /(?<type>[^\s]+)\s(?<name>[^\s]+)(?=\s\{get;)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<type>[^\\s]+)\\s(?<name>[^\\s]+)(?=\\s\\{get;)', 'g')
const str = `public class User
{
//Some code here
}
public class Cars
{
public string Brand {get; set;}
public string YearModel {get; set;}
public List<User> HasRented {get; set;}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}